WordPress 2.5.1 ist ein Sicherheits-Release, das ein schwerwiegendes, nicht genauer erläutertes, aber bald veröffentlichtes Sicherheitsproblem behebt. Desweiteren wurden über 70 weitere Fehler beseitigt, unter anderem:

  • Geschwindigkeitsverbesserungen im Backend
  • Geschwindigkeitsverbesserung bei der Verwendungen von vielen Kategorien
  • Fehler beim Upload in die Mediathek wurden beseitigt (Upload und Einbindung mit dem Internet Explorer sind jetzt möglich)
  • Der visuelle Editor TinyMCE hat ein Update auf Version 3.0.7 erfahren
  • Fehler bei der Widget Administration wurden beseitigt
  • Diverse Verbesserungen bei der Bedienung

Ein Upgrade auf die aktuelle Version wird dringend empfohlen.

Wer nur das Sicherheitsproblem beheben möchte, muss folgende Dateien herunterladen und aktualisieren:
wp-includes/pluggable.php, wp-admin/includes/media.php sowie wp-admin/media.php.

offizielles Entwicklerstatement mit weiteren Informationen
Download WordPress 2.5.1 (offizielle englischsprachige Version)

Vor einem Update unbedingt ein vollständiges Backup aller Dateien und der Datenbank angelegt werden.

_________

NACHTRAG: Das Upgradepaket für eine Aktualisierung von 2.5 auf 2.5.1 steht jetzt zum Download bereit. Das Upgradepaket beinhaltet alle geänderten Dateien zu der Vorgängerversion 2.5 und kann für eine Aktualisierung der offiziellen- und der DE-Edition benutzt werden.

Upgradepaket für 2.5 auf 2.5.1

Die Datei /wp-includes/js/tinymce/tiny_mce_gzip.php ist obsolet und kann nach der Aktualisierung gelöscht werden.

_________

Die DE-Edition werden wir schnellstmöglich nachreichen. Die DE-Edition ist nun fertig und kann heruntergeladen werden.